帝国CMS7.2搜索模板支持动态标签调用的修改代码方法

搬瓦工机场JMS

不知道为啥,帝国CMS搜索模板始终不支持动态标签调用,这很不方便,即便是升级到7.2,仍然不支持。

这篇文章成功实现了7.2版的搜索模板动态标签

教程开始

打开 /e/search/result/index.php 文件

查找:

require("../../class/connect.php");require("../../class/db_sql.php");require("../../data/dbcache/class.php");require("../../class/q_functiONs.php");require "../".LoadLang("pub/fun.php");

修改成:

require('../../class/connect.php');require('../../class/db_sql.php');require('../../class/functions.php');require('../../class/t_functions.php');require('../../data/dbcache/class.php');require "../".LoadLang("pub/fun.php");

接着查找:

//替换公共模板变量$listtemp=$tempr[temptext];

在上面添加以下代码:

//页面支持标签$tempr[temptext]=DtNewsBq('list'.$tempid,$tempr[temptext],0);

就可以了!

未经允许不得转载:Just My Socks中文教程网 » 帝国CMS7.2搜索模板支持动态标签调用的修改代码方法

赞 (0) 打赏
Just My Socks搬瓦工机场JMS

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏

微信扫一扫打赏